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Zoom Provisioning Error: "com.saasure.application.generic.client.AppApiException: javax.ws.rs.BadRequestException: HTTP 400 Bad Request"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Zoom provisioning flow fails with the following error visible in the Okta dashboard:

 

Automatic provisioning of user <username> to app Zoom failed: com.saasure.application.generic.client.AppApiException: javax.ws.rs.BadRequestException: HTTP 400 Bad Request

Applies To
  • Zoom
  • Provisioning
  • Error
Cause

The API authentication token or Zoom credentials used to create the API connection are invalid.

Solution
  1. Refer to Okta User Management with Zoom. On the Zoom side, verify the permission of the account used for creating the API connection.

  2. Go to the Okta admin panel and navigate to Applications > Zoom > Provisioning > Integration > Edit.

  3. Click Re-authenticate with Zoom. Sign in to the Zoom account with the Zoom admin's or owner’s credentials.
    Re-authenticate with Zoom 

  4. Back on the Provisioning page in Okta, see the message confirming successful authentication. Click Save.

  5. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks

           Tasks 

    6. After identifying the failed task for the user that should be retried, click Retry Selected.

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Zoom Provisioning Error: "com.saasure.application.generic.client.AppApiException: javax.ws.rs.BadRequestException: HTTP 400 Bad Request"