Workplace by Facebook Push Group Error "Error while creating user group: Unable add group member with id"
Okta Classic Engine
Okta Identity Engine
Okta Integration Network
Overview

Workplace by Facebook push group fails with the following error visible in the Okta dashboard:

Unable to update Group Push mapping target App group <group name>: Error while creating user group <group name>: Unable add group member with id = <externalID>

 

Applies To
  • Workplace by Facebook
  • Provisioning
  • Group Push
  • Okta Integration Network
Cause

The group push failed because the user with the given id, as stated in the Okta system log error message, was unable to be added as a group member.

Solution
  1. A pushed user must be active in Okta:
  1. must be assigned to the application,
  2. must be part of the Okta pushed group
  3. must be provisioned and active on the application side.
  1. Please validate the following for the user of the affected Push Group:
  • The user has an active account on the Workplace side.
  • The user's Username on the application assignment in Okta matches the value in the Workplace app.
  • The user account was not updated or changed on the Workplace side.
  1. Validate the user of the affected Push Group and make sure the user is provisioned successfully to Workplace.
  2. Go to Okta Admin Console and navigate to Applications > Applications > Workplace by Facebook > Push Groups, and attempt the group push again.

Recommended content