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Users Stuck in Activating State Due to Active Directory Assignment Failure
Okta Classic Engine
Directories
Okta Identity Engine
Overview

This article describes several possible causes and resolutions for the following error received when trying to activate a staged Okta user that is assigned to an Active Directory provisioning group:

An error occurred while assigning this app.
Automatic activation of user <username> to app Active Directory failed: Matching user not found.


 Error Message 

 

The user's Okta profile looks similar to:

User Profile

Applies To
  • Directories
  • Active Directory
  • LDAP
  • Staged Users
  • User Activation
Cause

This error is seen if anything prevents an Okta user from successfully provisioning to Active Directory via an Okta provisioning group while going from Staged to Active.

    Solution

    Provisioning from Okta to Active Directory may fail for many reasons. The following lists several potential causes and resolutions:

    • The "Create Users" option is not checked in the Active Directory integration.
      • Navigate to Directory Integrations > Active Directory > Provisioning > To App and ensure the Enable box is checked next to Create Users, then retry the task.
    Enable "Create Users" option

     

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    Users Stuck in Activating State Due to Active Directory Assignment Failure