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Invalid Directory Pathname Error Occurs When Provisioning an Okta User to Active Directory
Directories
Overview

An error occurs when Okta provisions a new user to Active Directory (AD) and passes an invalid value for the cn attribute. Updating the attribute mapping in the Profile Editor resolves this issue. During the provisioning process, Okta generates the following error:

 

An Invalid Directory Pathname was Passed

 

Applies To
  • Okta Identity Engine (OIE)
  • Okta Classic Engine
  • Directories
  • Active Directory (AD)
  • Provisioning
Cause

An invalid value for the cn attribute is passed during the provisioning process.

Solution

How is the invalid directory pathname error during Active Directory provisioning resolved?

 

Navigate to the Profile Editor to review the mapping for the cn attribute and determine why the expression fails to create a valid value for the user.

  1. Navigate to Directory > Profile Editor.
  2. Select the Directories filter.
  3. Select Mappings next to the AD instance experiencing the issue.

Profile Editor

  1. Select the Okta User to [Domain] at the top of the page.
  2. Review the mapping for the cn attribute and determine why the expression fails to create a valid value for the user.

 

NOTE: The default mapping for this attribute is user.firstName + " " + user.lastName.

 

Related References

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Invalid Directory Pathname Error Occurs When Provisioning an Okta User to Active Directory