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Error "An Invalid Directory Pathname was Passed" when Provisioning User to AD
Directories
Overview
This article explains the cause of the below error that appears when provisioning a new user from Okta to Active Directory.

An Invalid Directory Pathname was Passed 

 
Applies To
  • Directories
  • Active Directory
  • Provisioning To App
Cause
The error indicates that Okta is trying to pass an invalid value for the attribute cn.
Solution

Please follow the video below or the steps to review the mapping for the attribute cn in Profile Editor: 


 

  1. Navigate to Directory > Profile Editor.

  2. Select the Directories list in the middle.

  3. Select Mappings next to the directory having the issue.
    Profile Editor 

  4. Click Okta User to [Domain] at the top and review the mapping for cn and troubleshoot to determine why the expression is not creating a value for this user. The default mapping for this attribute is user.firstName + " " + user.lastName.


Related References

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Error "An Invalid Directory Pathname was Passed" when Provisioning User to AD