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Users Not Being Directed to Default Relay State Page During SP-Initiated Sign-On
Single Sign-On
Okta Classic Engine
Okta Identity Engine
Overview

After signing into Okta, users are redirected to the application's default landing page instead of the specified Default Relay State page during Service Provider (SP)-initiated sign-on.

Applies To
  • Default Relay State
  • Service Provider (SP)-initiated Sign On
Cause

During Security Assertion Markup Language (SAML) authentication, the Default Relay State configured is truncated after the "&" symbol.

Solution

To resolve the issue, follow the steps below:

  1. Copy the portion of Default Relay State beyond the "?" symbol. For instance, if the Default Relay State is: https://www.google.com/a/[DOMAIN]/ServiceLogin?continue=https://mail.google.com, copy continue=https://mail.google.com.

  2. Paste the copied text into the top field of a URL encoder.

  3. Click Encode.

  4. Copy the encoded value displayed: continue%3Dhttps%3A%2F%2Fmail.google.com.

  5. In the original Default Relay State value, replace the continue=https://mail.google.com portion with the copied encoded value continue%3Dhttps%3A%2F%2Fmail.google.com.

  6. The Default Relay State should now be: https://www.google.com/a/[DOMAIN]/ServiceLogin?continue%3Dhttps%3A%2F%2Fmail.google.com.

By following these steps, users will be directed to the specified Default Relay State page during SP-initiated sign-on instead of the application's default landing page.

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Users Not Being Directed to Default Relay State Page During SP-Initiated Sign-On