<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
User is Prompted for Factors After MFA Reset When Performing the Account Recovery Flow
Multi-Factor Authentication
Okta Identity Engine
Overview

Users are still prompted for the factors reset when going through the account recovery flow after the admin performs a factor reset.

Applies To
  • Multi-Factor Authentication
  • Okta Identity Engine
Cause

The enrolled factors (that users are allowed to use for recovery and set under (Settings > Security Methods) will still appear as an option for the end user even after an MFA reset when attempting to unlock the account or through the Self-service password reset.

Users should be able to configure communication channels and determine preferred methods for account recovery; this is an expected behavior.

Solution

Reset the specified factors.

  1. Have the end-user sign on to the End User Dashboard.
  2. Click on Settings.

Settings Page 

  1. Click Security Methods and reset the specified factor.
    Security Methods 
Loading
User is Prompted for Factors After MFA Reset When Performing the Account Recovery Flow