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Slack Provisioning Error "invalid_display_name" when Users Change the Display Name in Slack
Okta Integration Network
Overview

The Slack Application integration is configured with Provisioning API enabled on an Okta org.

In Directory > Profile Editor > Slack User > Mappings, the displayName attribute does not have the Okta User to Slack mapping as shown below:

Okta User to Slack mapping

Users are allowed to change their display name in Slack, as shown below:

Slack display name setting

Sometimes, a Slack User's display name does not match the display name in the Okta Slack App. It prevents user profile push updates, and Slack Provisioning fails with the error: 

Errors during execution: Error executing pushUserProfile: Bad Request. Errors reported by the connector : {"Errors":{"description":"invalid_display_name (user=<user>)","code":400}}. Error Code: null


Error Message


This article explains how to exclude the display name when pushing a user profile from Okta.

Applies To
  • Slack
  • Provisioning
Cause

This error is received because the provided display name is not allowed. The display name in Slack does not match the display name in the Okta Slack App.

invalid_display_name

This error is thrown because the provided display name is not allowed. The display name in Slack does not match the display name in the Okta Slack App.

Refer to this article for more details: Provisioning with SCIM.

Solution
  1. Okta does not support partial profile push. Okta pushes the app user's full profile during a profile update, including attributes set to Apply mapping on user create only and Do Not map. Refer to the following for more details: About profile push.  
  2. For the Slack app specifically, the Allow display name update setting under Provisioning > Integration prevents the display name from being sent in the System for Cross-domain Identity Management (SCIM) payload.
    Allow display name update 

    • When Allow display name update is not selected, Okta will not send display name updates to Slack. By default, this setting is disabled.

    • Setting Allow display name update grants the API token created permission to also perform the display name update from Okta to Slack and send the display name in the SCIM payload.

  3. Go to Okta Admin Console and navigate to Applications > Slack App > Provisioning > Integration > click the Edit button.

  4. Check if the Allow display name update setting is enabled. Uncheck this setting if it is not desired to update the display name from Okta to Slack.

  5. Once the Allow display name update setting was unchecked, attempt the user provisioning again.

 

Related References

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Slack Provisioning Error "invalid_display_name" when Users Change the Display Name in Slack