Okta Slack Provisioning Error invalid_display_name When Users Change Display Name
Last Updated:
Overview
A Slack provisioning error occurs in Okta when a user changes their display name in Slack, causing a mismatch with the Okta application profile. Resolving this issue requires disabling the display name update setting in the Slack application provisioning integration. The Slack application integration has the Provisioning Application Programming Interface (API) enabled, but the displayName attribute lacks the Okta User to Slack mapping, as shown in the following image.
Slack allows users to change their display name, as shown in the following image.
When a Slack user's display name does not match the display name in the Okta Slack application, it prevents user profile push updates, and Okta generates the following error.
Errors during execution: Error executing pushUserProfile: Bad Request. Errors reported by the connector : {"Errors":{"description":"invalid_display_name (user=<user>)","code":400}}. Error Code: null
Applies To
- Okta Identity Engine (OIE)
- Okta Classic Engine
- Slack
- Provisioning
Cause
The error occurs because the provided display name is not allowed. The display name in Slack does not match the display name in the Okta Slack application.
Refer to the Provisioning with SCIM documentation for more details.
Solution
How is the Slack invalid display name provisioning error resolved?
Disable the display name update setting in the Slack application provisioning integration and retry the user provisioning.
NOTE: Okta does not support partial profile push. Okta pushes the application user's full profile during a profile update, including attributes set to Apply mapping on user create only and Do Not map. Refer to About profile push for more details.
- Go to the Okta Admin Console and navigate to Applications > Applications > Slack > Provisioning > Integration.
- Select Edit.
- Clear the Allow display name update checkbox to prevent Okta from sending display name updates to Slack in the System for Cross-domain Identity Management (SCIM) payload.
- Retry the user provisioning.
