Slack Provisioning Error "{"Errors":{"description":"invalid_name_specials (user=<user>)","code":400}}. Error Code: null"
Okta Integration Network
Overview

Slack provisioning flow fails with the following error visible in the Okta dashboard:

Error while trying to push profile update for <username>: Errors during execution: Error executing pushUserProfile: Bad Request. Errors reported by the connector : {"Errors":{"description":"invalid_name_specials (user=<user>)","code":400}}. Error Code: null

Error Message

 
Applies To
  • Slack
  • Provisioning
  • Error
Cause

According to Slack's documentation, when provisioning a user via SCIM, the provided display name is not allowed because it contains invalid special characters such as @.

Error Example

Solution

Follow the steps or video below.



 

  1. Go to Okta Admin Console and navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.

 Tasks Dashboard 

  1. After identifying the failed task for the user that should be retried, click on the Edit Assignment button.

Edit Assignment Button

  1. Check the display name and remove invalid special characters in the Display name.

Edit User Assignment Page

  1. Also, check if the First name and Last name contain any invalid special characters and correct them if needed.
  2. Then click the Save Assignment and Retry button.

Save Assignment and Retry

  1. If the issue still persists, then please contact Slack support for more details and steps on how to resolve this invalid_name_specials error.


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