<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
"Sign Up" Link Missing from Okta Login Page During SP-initiated Login
Okta Identity Engine
Administration
Overview

When a user attempts to log into a specific application (using a Service Provider (SP)-initiated login URL), the Okta login page does not show the "Don't have an account? Sign up" footer.

Okta Login page 

Applies To
  • Okta Identity Engine (OIE)
  • Profile Enrollment
Cause

Users who complete self-service registration are not assigned to the target application. This applies to all application types.

Solution

Ensure the following:

  1. The application the user is attempting to access is assigned to a Profile Enrollment policy with Self-service registration set to Allowed.
  2. The application is assigned to users completing self-service registration. This can be completed in one of three ways:

 Federation Broker Mode

    • Assign the application to the "Everyone" group (not recommended; if all users in the Okta tenant should be assigned to this application, Federation Broker Mode is recommended instead).
    • Configure the Profile Enrollment policy to assign self-service registered users to a group assigned to the application (using the Add the user to group option, as shown below)

Profile Enrollment Policy, users assigned to groupApplication Assignments, group assigned to app

Result: 

Okta Login page 
 

Loading
"Sign Up" Link Missing from Okta Login Page During SP-initiated Login