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ServiceNow UD Provisioning Error "Errors found while setting values to the app user. Unsupported data type value for given key"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

ServiceNow UD provisioning flow fails with the following error visible in the Okta Dashboard:

 

Automatic provisioning of user <username> to app ServiceNow UD failed: Error while trying to import user profile for <username>: Could not deserialize. Errors found while setting values to the app user. appUserId=<appUserId>, errors=com.saasure.framework.validation.util.SimpleErrors: 1 errors Error in object 'appUser': codes [invalidValueTypeForProperty.appUser,invalidValueTypeForProperty]; arguments [department]; default message [Unsupported data type value for given key]

 

Applies To
  • ServiceNow UD
  • Provisioning
Cause

The attribute "department" has the data type unsupported. The department has recently been created or modified on the ServiceNow side. Okta will not be aware of this change until the ServiceNow integration data has been refreshed.

Solution
  1. ​​​​​In the Okta Admin Console, click on the Applications tab and click the affected ServiceNow app.
  2. Click on the Provisioning tab.
  3. Click the API Integration option from the left pane.
  4. Click Edit, then click Test API Credentials.
  5. A message should appear confirming successful authentication. Click Save.
  6. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.

 Tasks 

  1. After identifying the failed task for the user that should be retried, click on Retry Selected.

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ServiceNow UD Provisioning Error "Errors found while setting values to the app user. Unsupported data type value for given key"