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Salesforce Provisioning: Cannot Find the "API Enabled" Option in Salesforce
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

When an Okta admin attempts to re-authenticate the Salesforce provisioning connector in Okta, no errors are visible, and the provisioning flow fails to work.

Applies To
  • Salesforce
  • Provisioning
  • API
Cause

In the first step of the Okta documentation, it is required to:

  • Create an administrator account in Salesforce. This account is used to create an OAuth consumer key and consumer secret used in Salesforce REST integration.

This admin account must use a profile that gives access to the "API enabled" option; otherwise, the provisioning flow will fail.
In Salesforce, navigate to Setup > Profiles > select the appropriate profile > click Edit > enable API Enabled.

Permissions

Solution

If the API Enabled option is not visible, the wrong profile is selected, or an incorrect Salesforce Edition is used.

Check the default System Administrator profile. If the option is not there, it means that the wrong Salesforce subscription is being used.
About API feature 

 

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Salesforce Provisioning: Cannot Find the "API Enabled" Option in Salesforce