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Cannot Locate the "API Enabled" Option in Salesforce to Complete Salesforce Application Provisioning Configuration
Okta Integration Network
Okta Identity Engine
Overview

When attempting to reauthenticate the Salesforce provisioning connector in Okta, the provisioning flow fails, but no visible errors are displayed.

Applies To
  • Salesforce
  • Provisioning
  • API
  • Okta Identity Engine
Cause

The first step of our documentation states the following:

  • Create an administrator account in Salesforce. This account will be used to create an OAuth consumer key and consumer secret, which will be further used in the Salesforce REST integration.

This admin account must use a profile that gives access to the "API enabled" option; otherwise, the provisioning flow will fail.

Administrative Permissions

Solution

If the API Enabled" option is not visible, then either the wrong profile is used or the wrong Salesforce Edition.

Check the default "System Administrator" profile. If the option is not there, it means that the wrong Salesforce subscription is used.
The API is automatically enabled by default on the following editions 

 
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Cannot Locate the "API Enabled" Option in Salesforce to Complete Salesforce Application Provisioning Configuration