<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
RDP Error when Connecting via Okta PAM "Remote Desktop Connection could not find the destination computer"
Okta Classic Engine
Privileged Access
Okta Identity Engine
Advanced Server Access
Overview

When a user tries to connect to a server via Remote Desktop Protocol (RDP), they are presented with the following error:

 

Remote Desktop Connection could not find the destination computer. This can happen if the computer name is incorrect or the computer is not yet registered with the RD Connection Broker. Try connection again, or Contact your network administrator. 

 

The Remote Desktop Protocol (RDP) window will display, and then the RDP error will be shown. This indicates that the OPA client is able to establish a connection with the OPA server agent broker service, which is listening on port 4421. However, the connection from the broker service to the server's 3389 port is getting dropped.

 

RDP Error

Applies To
  • Okta Privileged Access 
  • Advanced Server Access
  • Remote Desktop Protocol (RDP)
Cause

The RDP Connection Broker service is running on the server.

Solution

Follow the below steps to resolve this issue: 

  1. Stop the RDP connection Broker Service on the target server.
  2. Connect to the server.
Loading
RDP Error when Connecting via Okta PAM "Remote Desktop Connection could not find the destination computer"