<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
ASA/OPA - Unable to RDP to Windows Server and Receiving "error: tls: bad certificate" when Trying to Connect
Advanced Server Access
Okta Classic Engine
Okta Identity Engine
Overview

When trying to RDP from a client with ScaleFT to Windows, the target server is unable to connect.  The following error appears as a result:

 

INFO Background client: Display modal error: title=RDP URL error body=rpc error: code = Unavailable desc = connection error: desc = "error reading server preface: remote error: tls: bad certificate 

Applies To
  • Remote Desktop Protocol (RDP)
  • ASA/OPA
  • ScaleFT Client 
  • Windows Target Server running ScaleFT Server Agent
Cause

The time between the system and the target server was out of sync.

Solution

Synchronize clocks on the ScaleFT client and the Target server.

 

NOTE:  It is recommended to utilize NTP in the environment to keep all servers' clocks in sync.

Loading
ASA/OPA - Unable to RDP to Windows Server and Receiving "error: tls: bad certificate" when Trying to Connect