Okta Error Occurs When Using the Same Email Address for Custom Email Domains Across Brands
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Overview
An error occurs when an administrator attempts to use the same email address across different brands for custom email domains, because each unique email sender can be used only once per cell. Resolve this issue by using subdomains or copying the email domain to another brand. When an administrator attempts to add the same email address to a different brand, Okta generates the following error message:
domain: Email domain already exists.
Applies To
- Okta Identity Engine (OIE)
- Okta Classic Engine
- Custom Email Domain
- Brands
Cause
Okta’s main email provider requires each unique email sender, such as a root domain like <no-reply@company.com>, to be used only once in each cell.
Solution
How can an Okta Administrator use subdomains to maintain unique email senders?
Maintain unique email senders by using subdomains for different brands. For example:
<no-reply@brandA.company.com><no-reply@brandB.company.com>
How can an Okta Administrator copy the email domain to another brand using the Okta Admin Console?
Navigate to the Brands menu, access the Domains section, and copy the email domain to the target brand.
- Navigate to Customizations > Brands >
<BRAND>. - Navigate to Domains.
- Access the Actions menu in the Emails section and select Edit, followed by Copy to another brand.
- Choose the destination brand from the menu and select Copy domain.
NOTE: Currently, the Okta Admin Console does not support copying custom email domains from a custom brand to the default brand. This configuration requires the use of the Brands API.
