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Okta Access Gateway Auto Update Fails on GCP Node with Error "Reason: Bus n/a: changing state UNSET → OPENING"
Okta Classic Engine
Access Gateway
Okta Identity Engine
Overview

This article describes an issue in which the Okta Access Gateway (OAG) auto-update fails on a Google Cloud Platform (GCP) node. When the update process runs, the following error occurs:

 

Error while running autoupdate: Failed to backup OAG configuration. Reason: Bus n/a: changing state UNSET → OPENING

 

Applies To
  • Okta Access Gateway (OAG)
  • Google Cloud Platform (GCP)
  • Auto Update
Cause

GCP environments have additional system debug logging enabled by default. The auto backup mechanism expects the process to produce blank output; however, the additional debug output in GCP is incorrectly interpreted as a failure.

Solution

This issue is scheduled to be fixed in release 2026.3.0. To resolve this, manually upgrade the OAG node to version 2026.3.0 or later when it becomes available.

 

Follow these steps to apply a workaround by disabling GCP debug logging:

  1. Open the OAG Console Shell.

  2. Enter the following command:

    sudo grubby --remove-args=debug --update-kernel=ALL

  3. Reboot the node for the changes to take effect.

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Okta Access Gateway Auto Update Fails on GCP Node with Error "Reason: Bus n/a: changing state UNSET → OPENING"