Office 365 Provisioning Error "License assignment failed because service plan A depends on the service plan(s) B"
Okta Identity Engine
Okta Integration Network
Overview

This article explains why the following error occurs when attempting to provision licenses in Office 365: 

 

License assignment failed because service plan A depends on the service plan(s) B

 

Applies To
  • Office 365
  • Provisioning 
  • Okta Integration Network (OIN)
  • Okta Identity Engine (OIE)
Cause

The error indicates that Microsoft does not allow the assignment of license A because it is dependent on license B, which is missing from the user's license assignment. This is a Microsoft error, as Okta sends the request to Microsoft, and Microsoft rejects the license assignment due to a missing license dependency.

Solution
  1. Run the Microsoft PowerShell command to confirm the license dependency, as indicated by the error.
  2. Update the Okta application assignment or license assignment to include the missing dependent license.
  3. Retry the provisioning task.
  4. If additional details are needed, involve Microsoft support.

 

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