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OAG: java.lang.OutOfMemoryError: Java Heap Space
Access Gateway
Okta Classic Engine
Okta Identity Engine
Overview

The Admin UI is sluggish or slow with the following errors in UI and logs: 

Server Side Error occurred
Server side exception has been logged.
Please notify support.

 

Error message 
 

2023-08-03T03:12:55.000-07:00 localhost ACCESS_GATEWAY WEB_CONSOLE handleExceptions
2023-08-03T03:12:55.000-07:00 localhost org.springframework.web.util.NestedServletException Handler dispatch failed; nested exception is java.lang.OutOfMemoryError: Java heap space

 

Applies To
  • Okta Access Gateway (OAG)
  • Access Gateway Admin Service
  • Admin UI
Cause

The OAG-admin service was running Out Of Memory, causing the service to not run optimally.

Solution

As this error is caused by a lack of available heap memory for the Admin Service, the solution involves increasing the maximum amount of heap memory available to the Admin Service:

  • If OAG is on version prior to 2024.6.1, we recommend upgrading to version 2024.6.1 or later.
    • Starting in version 2024.6.1, the default maximum heap memory for the Admin Service is increased from 256 MB to 512 MB.
  • If the issue continues to occur on version 2024.6.1 or newer, increase the maximum memory assigned to the Admin Service from the OAG Management Console. The steps to configure this can be found in Access Gateway Admin.

For assistance with evaluating the size of memory to assign and/or experiencing the issue but unable to upgrade to version 2024.6.1 or later, please contact Okta Support.

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OAG: java.lang.OutOfMemoryError: Java Heap Space