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OAG: After Upgrading to 2024.9.2 CLI Session Timeout after 5 Minutes
Access Gateway
Okta Classic Engine
Okta Identity Engine
Overview

When logged in to the shell through the management console, the session closes after 5 minutes, even while active. If the connection is slow, this can also cause issues with a timeout during upgrade.

Applies To
  • Okta Access Gateway (OAG)
  • 2024.9.2
Cause

Because of security reasons, the idle session timeout has been set to 5 minutes on OAG appliances. When a local shell is accessed from the management console, a different user is used than oag-mgmt. In doing so, the oag-mgmt user remains idle, and the CLI session will exit after 5 minutes.

Similar behavior might be observed during upgrade when connection from appliance to the repo server is slow.

Solution

Following steps can be used from shell to increase the session to 15 minutes in case extended CLI session is required for an activity.

 

NOTE: Because of security reasons it is only recommended to change the session timer for the duration of the activity and revert once it gets completed.

 

To change the session timeout to 15 minutes:

sudo /opt/oag/scripts/mgmt/setSessionTimeout.sh 900

Once the activity is completed then revert the timeout settings to the default value: 

sudo /opt/oag/scripts/mgmt/setSessionTimeout.sh 300

 

Please reach out to support if the upgrade gets timed out after setting the timer to 15 minutes.

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OAG: After Upgrading to 2024.9.2 CLI Session Timeout after 5 Minutes