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Microsoft Office 365 Import Error "Could not validate your Office 365 credentials, received error: 400 AADSTS50126"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

This article discusses why Microsoft Office 365 import fails with the following error:

An error occurred during import
Could not validate your Office 365 credentials, received error: 400 AADSTS50126: Error validating credentials due to invalid username or password Trace ID: <trace ID> Correlation ID: <correlation ID> Timestamp: <timestamp>

 

O365 error

Applies To
  • Microsoft Office 365 (O365)
  • Import
  • Error
Cause

This error is caused by the invalid Office 365 Global Administrator credentials used to create the API connection.

Solution
  1. Navigate Microsoft Office 365 > Provisioning > Integration > Edit.
  2. Click Re-authenticate with Microsoft Office 365. It is expected to see a new pop-up window being opened automatically and being redirected to the Microsoft Azure login page. Before performing this step, please check the web browser settings to turn off any pop-up window blocker.
  3. Log in to the Microsoft Azure account using Office 365 Global Administrator credentials. 
  4. Read and accept the requested permissions. Upon accepting the scopes in the Microsoft Azure portal, the page is redirected back to Okta.
  5. Enter the same Office 365 Global Administrator credentials on the Integration page and click Test API Credentials.
  6. After the credentials are verified successfully, click on the Save button. 
  7. Attempt the import again. It should complete the import successfully. 
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Microsoft Office 365 Import Error "Could not validate your Office 365 credentials, received error: 400 AADSTS50126"