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Office 365 Provisioning "400 Authentication Error"
Okta Integration Network
Overview

Application assignment or profile push for Office 365 application failed with one of the errors below:

Automatic provisioning of user to app Microsoft Office 365 failed: Could not validate your Office 365 credentials, received error: 400 AADSTS50126: Error validating credentials due to invalid username or password.

 

Automatic provisioning of user to app Microsoft Office 365 failed: Could not communicate with Office 365 to validate your credentials, received error: 400 Authentication Error: Password has expired.
 

Applies To
  • Microsoft Office 365 Provisioning
  • Okta Administration
  • Microsoft Office 365 
Cause

API credentials provided in Okta for provisioning are no longer valid.

Solution
  1. On the Okta Admin Console, navigate to Applications > Microsoft Office 365
  2. Select the Provisioning tab.
  3. Select the API Integration tab on the left and then click Edit
  4. Update the new credentials of a Global or Company Administrator account in Office 365.
  5. Validate the credentials by clicking on Test API credentials
  6. Click on Save.
  7. Navigate to Dashboard > Tasks
  8. Filter the tasks by application.
  9. Retry all the tasks that originally failed with the above error.
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Office 365 Provisioning "400 Authentication Error"