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Microsoft 365 Error During Group Push or Import I/O error on POST request for "https://login.microsoftonline.com/common/oauth2/token"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Microsoft Office 365 Push Group or Import fails with the following error visible in the Okta dashboard:
 

Changes to the Group push mapping for the group XXXXX could not take effect due to error: Login failed with org.springframework.web.client.ResourceAccessException: I/O error on POST request for "https://login.microsoftonline.com/common/oauth2/token": cannot retry due to server authentication, in streaming mode; nested exception is java.net.HttpRetryException: cannot retry due to server authentication, in streaming mode

Import Error: Login failed with org.springframework.web.client.ResourceAccessException: I/O error on POST request for "https://login.microsoftonline.com/common/oauth2/token": cannot retry due to server authentication, in streaming mode;
Applies To
  • Microsoft Office 365
  • Provisioning
  • Group Push
  • Import
  • Error
Cause

This error appears because the Office 365 Global Administrator credentials for creating the API connection are invalid.

Solution
  1. Go to the Okta Admin Console, navigate to Applications > Applications > Office 365 > Provisioning > Integration, and click Edit.
  2. Click Re-authenticate with Microsoft Office 365. The Microsoft Azure login page appears.
  • Log into the Microsoft Azure account.
  • Read and accept the requested permissions.
  • Upon accepting the scopes in the Microsoft Azure portal, the page is redirected back to Okta.
  1. A message confirming successful authentication is generated. Click Save
  2. Then navigate to Office 365 > Push Groups or Import, and attempt again.
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Microsoft 365 Error During Group Push or Import I/O error on POST request for "https://login.microsoftonline.com/common/oauth2/token"