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Microsoft 365 Provisioning Error: I/O Error on POST Request
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Microsoft Office 365 provisioning flow fails with the following error visible in the Okta dashboard:

 

Automatic provisioning of user <user name> to app Microsoft Office 365 failed: Login failed with org.springframework.web.client.ResourceAccessException: I/O error on POST request for "https://login.microsoftonline.com/common/oauth2/token": cannot retry due to server authentication, in streaming mode; nested exception is java.net.HttpRetryException: cannot retry due to server authentication, in streaming mode

 

Error Message

 
Applies To
  • Microsoft Office 365
  • Provisioning
  • Error
Cause

This error occurs because the Office 365 Global Administrator credentials used to create the API connection are invalid. 

Solution
  1. Go to Okta Admin Console, navigate to Applications > Applications > Office 365 > Provisioning > Integration > click Edit.
  2. Click Re-authenticate with Microsoft Office 365. The Microsoft Azure login page appears.
    1. Log in to the Microsoft Azure account.
    2. Read and accept the requested permissions.
    3. Upon accepting the scopes in the Microsoft Azure portal, the page is redirected back to Okta.
  3. Enter the valid Office 365 Global Administrator credentials.
  4. Click Test API Credentials.
  5. A message confirming successful authentication is generated. Click Save.
  6. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.
Tasks
  1. After locating the failed task for the user that should be retried, click on Retry Selected.
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Microsoft 365 Provisioning Error: I/O Error on POST Request