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How to Request a Rate Limit Increase
Administration
Okta Classic Engine
Okta Identity Engine
Overview

This article describes how to request a rate limit increase and the information that needs to be provided with the request.

A rate limit increase can be requested by opening a Support case to increase the rate limit for specific Okta API endpoints. These requests must be submitted at least 15 business days before the increased rate limit is needed. Once submitted, Okta will review each request thoroughly and either grant or deny it. Okta strongly recommends submitting requests as far in advance as possible since some requests may take longer to review.

Requests can be submitted for the following customers:

  • Workforce Identity Cloud (WIC) customers
  • Customer Identity Solution (CIS) customers

Each request is evaluated independently. Approval of a previous request does not guarantee future approval. Okta assesses the impact of each request on system performance and available capacity at the time of submission.

NOTE: If approved, increases in the form of Burst Rate Limits (BRL) do not take effect unless the API tokens are at 100%.

Rate limit increases on endpoints for administrative actions (such as creating or modifying users, groups, applications, etc.) are less likely to be approved due to the additional complexity involved.

If a request is made for endpoints covered by Dynamic Scale or Workforce Multipliers, Okta may deny the request and recommend a consultation with the account team to explore purchasing Dynamic Scale or increasing the Workforce Multiplier. Typically, this would occur if:

  • A temporary rate limit increase has been requested multiple times in a calendar year.
  • A rate limit increase that is >= 5x the default rate limit is requested (for example, 1,000 requests per minute to 5,000 requests/min).
  • A permanent rate limit increase is requested. 
Applies To
  • Rate Limiting
  • Rate Limit Warning
  • Rate Limit Violation
  • Okta Classic Engine
Cause

Higher rate limits are required than the default rate limits provided by Okta.

Solution

Please provide the following information. Failure to provide accurate information may result in a delay or denial of the request.

NOTE: Okta may raise or lower the limits without notice in the process of maintaining the service. Okta reserves the right to rate limit other functionality to prevent abuse, spam, denial-of-service attacks, or other security issues.

Organization Information:

  • Org Name:
  • Org URL: 

Request Details:

  • Start Time:
  • End Time: (if permanent request, then please make end-time as “Permanent”)
  • Rate Limit Increases:
    • Exact API URI: (for example, api/v1/users/factors/{factorsId} instead of just api/v1/users)
      • Operation: Read or Write (the data will only be read, or there will be a try to create/update data?)
      • Target Rate Limit:
      • Rationale for Target Rate Limit: 
  • Business Justification for Increase: If it is a Permanent Request, please justify why the temporary request is not an option.

  • Additional Information: Any additional context or evidence that justifies the rate limit increase request (for example, auth flows, process flows, volume of requests, performance test results, etc.).

  • If applicable:

    • How many events will be generated as part of user creation?

    • Will the system be sending usernames/passwords?

    • If so, are they sent in MD5 Hash or plain text?

    • Will users be enrolled in SMS or Voice factors? If yes, how many of each?

    • What will the SMS traffic per second be?

    • How many SMS enrollments per hour are expected to be sent?

    • How many SMS verifications per hour?

    • To which countries will the SMS be sent?

    • Has the organization configured proxy servers in a country other than the one where most users are based?

    • Will there be group assignments? If yes, how many?

    • Will there be any app assignments? If yes, how many?

    • Can the workflow used during this event be explained?

NOTE: Before approving increases, Okta Support may require additional documentation and endpoint usage (minimum 1,000 requests per endpoint over 7 days). Rate limit increases for an endpoint may be denied if three or more rate limit increases were granted for that endpoint in the past 12 months. If this happens, it may be necessary to speak to the designated Account Team about Dynamic Scale. When submitting the request, please provide comprehensive historical usage data, including peak traffic metrics, alongside detailed business cases that justify the need for a rate limit increase. 

 

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How to Request a Rate Limit Increase