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Error "You do not have permission to access the feature you are requesting" when Using the MyAccount Update Password Endpoint
Administration
Okta Identity Engine
Overview

This article explains what causes the MyAccount Update a Password endpoint, /idp/myaccount/password/change-password to return the following 401 error: 

 

You do not have permission to access the feature you are requesting.

 

Applies To
Cause

In order to use the MyAccount Update a Password endpoint, the org must be on Okta Identity Engine (OIE), and the End User Settings version 2.0 feature must be enabled in the org. If this feature is not enabled, the /idp/myaccount/password/change-password endpoint will return a 401 response.

Solution

Please review the How to Enable End User Settings Version 2.0 article to ensure that it is enabled.

 

End User Settings version 2.0

 

NOTE: Requests to this endpoint require authorization by an Access Token (sent as a bearer token) that has been granted the `okta.myAccount.password.manage` scope.

Related References

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Error "You do not have permission to access the feature you are requesting" when Using the MyAccount Update Password Endpoint