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Error "404 Not Found" when Attempting to Create or Reauthorize a OneDrive Connection in Workflows

Workflows
Okta Classic Engine
Okta Identity Engine

Overview

The following error occurs when attempting to create or reauthorize a OneDrive connection in Workflows:

 

404 Not Found

 

Error

Applies To

Cause

The Microsoft account being used to Authorize the connection does not have OneDrive associated with it, and the API endpoints used from Microsoft's side expect the authorized user to be a OneDrive user as well.

 

This can be confirmed by trying to access OneDrive in a web browser for the logged Microsoft user and not being able to see/use OneDrive for the desired user.

Solution

To resolve this, please use the Microsoft admin account to set up the connection and associate OneDrive with it.

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Okta Support - Error "404 Not Found" when Attempting to Create or Reauthorize a OneDrive Connection in Workflows