Error "401 The caller does not have permission" when Authorizing a Google Drive Connection in Workflows
Last Updated:
Overview
{
"error": {
"code": 401,
"message": "The caller does not have permission",
"errors": [
{
"message": "Active session is invalid. Error code: 4",
"domain": "global",
"reason": "authError",
"location": "Authorization",
"locationType": "header"
}
],
"status": "PERMISSION_DENIED"
}
}
Applies To
- Okta Workflows
- Google Drive Connector
- Okta Identity Engine (OIE)
- Okta Classic Engine
Cause
This error can occur if the Google Drive and Docs service is turned off for the Google Workspace user attempting to authorize or test the connection.
Solution
In the Google Admin Console:
- Navigate to Apps > Google Workspace > Drive and Docs.
- Click on Service status.
- Check to see if the service is disabled for the user attempting to authorize the Google Drive connection in workflows.
- NOTE: The service can be turned on/off for all users or specific users based on Groups or Organizational Units.
- Ensure the service is enabled for the user and attempt to reauthorize the connection.
