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Error "The domain administrators have disabled Drive apps" when Authorizing a Google Drive Connection in Workflows
Workflows
Okta Classic Engine
Overview

The following error occurs when attempting to create, test, or reauthorize a Google Drive connection in Workflows:
 

{
    "error": {
        "code": 403,
        "message": "The domain administrators have disabled Drive apps.",
        "errors": [
            {
                "message": "The domain administrators have disabled Drive apps.",
                "domain": "global",
                "reason": "domainPolicy"
            }
        ]
    }
}

 

Applies To
  • Okta Workflows
  • Google Drive Connector
  • Google Sheets Connector
  • Okta Classic Engine
Cause

This error indicates that access to the Google Drive SDK API is not enabled, causing a permissions error. Note that the Google Sheets connector for Workflows also requires the Google Drive SDK to be enabled. However, when attempting to authorize the Google Sheets connector, the "403 Forbidden" error will be received rather than the "The domain administrators have disabled Drive apps." error if the Drive SDK API is not enabled.

Solution

Enable the Google Drive SDK API using the following steps:

  1. In the Google Admin console, navigate to Apps > Google Workspace > Drive and Docs > Features and Applications.
  2. In the Organization Units section, select the OU that the account used to authorize the Google Drive connection resides in.
  3. Click on Drive SDK and check Allow users to access Google Drive with the Drive SDK API to enable the Drive SDK.
DriveSDK
 
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Error "The domain administrators have disabled Drive apps" when Authorizing a Google Drive Connection in Workflows