AWS IAM Identity Center Push Group Error "Errors reported by remote server: MEMBER does not exist"
Last Updated:
Overview
AWS IAM Identity Center push group fails with the following error visible in the Okta dashboard:
Unable to update Group Push mapping target App group <group name>: Error while updating user group membership for group <group name>: Not Found. Errors reported by remote server: MEMBER does not exist
Applies To
- AWS IAM Identity Center
- Provisioning
- Group Push
- Error
Cause
If one of the users in the group you are trying to push to the AWS IAM Identity Center app has a provisioning error, the push is unsuccessful and this error is thrown "Errors reported by remote server: MEMBER does not exist".
Solution
-
Make sure all members of the affected Push Group do not have any provisioning errors and are provisioned successfully in the AWS application side/Okta assignments tab.
-
After you find and fix the user's provisioning error, go to Okta Admin Console and navigate to Applications > Applications> AWS IAM Identity Center > Push Groups, and attempt the group push again.
