LaunchDarkly Push Group Error "Errors reported by remote server: member ID "<app user external ID>" does not exist"

Okta Classic Engine
Okta Identity Engine
Okta Integration Network

Overview

LaunchDarkly push group fails with the following error visible in the Okta dashboard:

Unable to update Group Push mapping target App group <group name>: Error while updating user group membership for group <group name>: Bad Request. Errors reported by remote server: member ID "<app user external ID>" does not exist

 

Applies To

  • LaunchDarkly
  • Provisioning
  • Push Groups
  • Error

Cause

The group push failed because the user, as stated in the Okta system log error message, was not found and is missing on the LaunchDarkly side. 

Solution

  1. A pushed user must be active in Okta, assigned to the application, part of the Okta pushed group, and provisioned and active on the application side.
  2. Please validate the user listed in the Okta system log error message for the affected Push Group:
  • The user has an active account on the LaunchDarkly side.
  • The user's External ID on the application assignment in Okta matches the value.
  • The user account was not updated or changed on the LaunchDarkly side.
  1. Validate and fix the listed user, then navigate to the Okta Admin Console, go to Applications > Applications > LaunchDarkly > Push Groups, and attempt the group push again.

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