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Okta Access Gateway: After Upgrade to 2024.11.1 the Admin UI Cannot Be Accessed
Access Gateway
Okta Classic Engine
Okta Identity Engine
Overview

After upgrading to version 2024.11.1, while trying to access the admin UI, the errors below are seen:

 

"code": "UNHANDLED"

"message": "Cannot run program \"/opt/oag.bin/checkDefaultPassword.sh\": error=2, No such file or directory"

 

Error

Text version of the error shown above

{ "type": null, "status": 0, "code": "UNHANDLED", "message": "Cannot run program \"/opt/oag/bin/checkDefaultPassword.sh\": error=2, No such file or directory", "developerMessage": null, "errors": { }, "context": null }

 

In the ics_all.log, the error will be seen as follows:

2024-12-10T09:13:24.000-05:00 oag.support.lab ACCESS_GATEWAY WEB_CONSOLE handleExceptions
2024-12-10T09:13:24.000-05:00 oag.support.lab java.io.IOException Cannot run program "/opt/oag/bin/checkDefaultPassword.sh": error=2, No such file or directory
 
Applies To
  • Okta Access Gateway (OAG) Version 2024.11.1
  • Okta Classic Engine
  • Okta Identity Engine (OIE)
Cause

When specific packages are updated, for them to start and run properly, they must be restarted. For this reason, a reboot is required. 

Solution

To resolve the error:

  1. Follow all steps in the Okta Access Gateway release notes documentation, including the reboot after upgrading.
  2. Once the server has been rebooted, please access the admin UI.
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Okta Access Gateway: After Upgrade to 2024.11.1 the Admin UI Cannot Be Accessed