Okta Access Gateway Upgrade Fails For Admin UI Package On Worker Nodes
Last Updated:
Overview
An Okta Access Gateway (OAG) upgrade failure occurs for the Admin UI package on worker nodes because the backup process deletes the UI database file. Executing the upgrade steps again and removing the dependency package resolves the issue.
When upgrading worker nodes to version 2024.1, the following error appears for the Admin UI package:
Upgrading : okta-admin-ui-2024.1.1-ec4754a21.x86_64 190/474Error unpacking rpm package okta-admin-ui-2024.1.1-ec4754a21.x86_64
error: unpacking of archive failed on file /opt/oag/data/db/spgwadmin.h2.db: cpio: chown failed - Inappropriate ioctl for device
error: okta-admin-ui-2024.1.1-ec4754a21.x86_64: install failed
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Failed:
okta-admin-ui-2023.11.0-ac5d9783d.x86_64
okta-admin-ui-2024.1.1-ec4754a21.x86_64 Error: Transaction failed
NOTE: The Admin UI service does not reside on worker nodes, so there is no impact from the failure.
Applies To
- Okta Identity Engine (OIE)
- Okta Classic Engine
- Okta Access Gateway (OAG) Version 2024.1
Cause
The backup process deletes the UI database file on the worker nodes, which results in an admin-ui package installation error because Okta Access Gateway cannot locate the file. The UI database only exists on the Admin node, so this does not impact any service. This issue is resolved in version 2024.2.1.
Solution
How is the Admin UI package upgrade failure resolved?
Execute the upgrade steps again through the management console and remove the dependency package to resolve the upgrade failure.
- Execute the upgrade steps again through the management console. A prompt appears stating that only a few dependencies require updates. The process completes quickly after confirmation because only one package requires installation.
- Navigate to the Remove Package option.
- Enter "okta-deps-ova" to remove. This is required to avoid any issues while upgrading a specific package in the future.
