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Add okta.myAccount.* Reserved Scopes to a Custom Authorization Server
API Access Management
Okta Classic Engine
Okta Identity Engine
Overview

Before July 2024, Okta displayed okta.myAccount.* scopes within a Custom Authorization Server's Scope page by default. However, as of July they will need to be added manually in the Scope table.

Applies To
  • Custom Authorization Server
  • API Access Management
Cause

okta.myAccount.* scopes do not show up in the Scopes tab for a Custom Authorization Server.

test scope

Solution

All scopes documented in MyAccount Management need to be manually added by going to Security > API. Then, after selecting the Custom Authorization Server, select the Scopes tab, and then add a scope by:

  1. Click the Add Scope Button.

test scopes

  1. Add one of the okta.myAccount.* scopes and click Create

Add scope

  1. The scope will be added at the top of the table.

test scope

NOTE: Okta also reserves the okta.* namespace, so arbitrary scopes with okta.* cannot be created. Only the ones listed in the above link are permitted.

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Add okta.myAccount.* Reserved Scopes to a Custom Authorization Server