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Workday Email Writeback Not Triggered Immediately Upon Okta New User Account Creation via Workday Import
Lifecycle Management
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

This article will explain the fundamental reason why the Workday Email Writeback feature is not triggered immediately after a new Okta user account is created via a Workday import, when using the out-of-the-box configuration.

Some Admins may have a specific business use case in which a Workday user does not have a Work Email configured in the Workday external application upon Workday user creation. Instead, Admins will rely on Workday Provisioning > To Okta > Attribute Mapping > Email attribute field mapping OEL feature to generate the appropriate Work Email for each Workday imported user as part of the Okta user profile creation via the Workday import job run. Then, the next step would be utilizing the Okta-supported Workday Email Writeback feature, which is intended to sync the generated Okta user's email value with the corresponding Work Email attribute in Workday for each newly assigned Okta Workday application user.

The process flow largely works as intended: The Workday Import job is completed, triggering the new Okta user creation with the expected email value, and the user is correctly assigned to Workday.

However, Admins may notice that the process is not fully automated. The final required step, Workday Email Writeback, does not trigger immediately to sync the correctly mapped Okta email value back to the corresponding Workday user profile.

Applies To
  • Workday
  • Okta/Workday Email Writeback feature
Cause

In this case, the behavior is working as designed out of the box. The mapped Okta Email field value used for Workday Email Writeback sync is set during the initial creation of the Okta user, which is triggered by the Workday import. Since there are no subsequent updates to the mapped Okta Email field in the Okta user profile after creation, the system does not automatically trigger a Push User Profile Update to Workday for the purpose of syncing the email via Workday Email Writeback.

Solution

For out-of-the-box solutions, if an Admin has a need to trigger Workday Email Writeback immediately after importing users from Workday, the Okta Admin must manually perform a Force Sync from the Okta Admin DashboardApplications > Workday app > Provisioning > To App page, following each import job run, for all newly imported users assigned to the Workday application.

If Admins would like to avoid the manual Force Sync step to fulfill a specific business need, Okta recommends that Admins contact our Okta Professional Service team, who may help them design a custom-designed business solution for a fully automated business process flow that allows them to trigger the Workday Email Writeback automatically for each newly created Okta user after Workday import. This is possible but not limited to Okta Workflow  implementation depending on the specific business requirement.

NOTE: Custom solution design/consultation inquiry is outside the scope of Okta Customer Support, where Okta Customer Support is a break/fix service providing assistance in resolving existing implementations that are already designed to work.


Related References

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Workday Email Writeback Not Triggered Immediately Upon Okta New User Account Creation via Workday Import