Meaning of the Deferred Email Status in the Okta System Log
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Overview
A DEFERRED email status appears in the Okta System Log when a recipient server temporarily rejects an email and waits for a retry. Administrators must check the receiving email server configuration and spam filters to ensure it accepts incoming messages from Okta.
Applies To
- Okta Identity Engine (OIE)
- Okta Classic Engine
- System Log
- Email Delivery
Cause
A deferral occurs when a recipient server is not ready to accept an email from an IP address or domain. Instead of blocking or bouncing the message, the recipient server defers receiving the email and waits for Okta to retry the delivery.
Solution
How is a deferred email status resolved?
The recipient server temporarily rejects the email and waits for a retry. Check the email server to determine the reason for the deferral and ensure that the server accepts incoming emails. Spam filters on the email client or server might reject emails from Okta.
Locate emails that fail delivery with a DEFERRED reason by running the following query in the System Log.
eventType eq "system.email.delivery" and outcome.result eq "FAILURE" and outcome.reason eq "DEFERRED"
