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User Profile Values not Reflecting BambooHR Profile Source Values
Lifecycle Management
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

This article addresses the scenario where attribute values in an Okta user profile do not match the corresponding values in the BambooHR App user profile.

Applies To
  • BambooHR
  • Profile Source
Cause
This issue may be caused by the attribute level sourcing setting being set to "Inherit from Okta." When an attribute is set to "Inherit from Okta" with its profile source priority, the value will not be synchronized from BambooHR to Okta. 
 
Solution

To help resolve this issue, Admins can perform one of the options below:

  1.  Adjust attribute sourcing:
    1. Navigate to Directory > Profile Editor > Select Profile for the Okta application.
    2. Select the i icon for the attribute or attributes listed in the system log. 
    3. Adjust Source Priority back to Inherit from profile source.
Source Priority
  1. Adjust BambooHR profile mappings:
    1. Navigate to Directory > Profile Editor > select Configure User mappings for the BambooHR application.
      Configure User mappings 

    2. Under the BambooHR to Okta User tab, scroll down to the fields not updated. 
      BambooHR to Okta User tab 

    3. Either adjust the mapping to create only (select Yellow Arrow) or remove it entirely if it is no longer required.
  1. Reach out to Okta Support to confirm if there is any attribute constraint that is not reported in Okta System Logs and is only reported in verbose logging. 
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User Profile Values not Reflecting BambooHR Profile Source Values