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User with Staged Status is Set to Active when Pressing Activate Instead of Pending User Action
Lifecycle Management
Okta Classic Engine
Okta Identity Engine
Overview

Okta supports creating users in the "Staged" status, which requires users to log in and complete the email activation process to set up their credentials. 

 

It might be noticed that when pressing the Activate button for a "Staged" user, the status changes to "Active" instead of "Pending User Action".

 

This article explains this behavior.

 

Applies To
  • Staged Users
  • Activation emails
Cause

Accounts are initially created in a "Staged" state, prior to the initiation of the activation process, or in the event of a pending administrative action.

Solution
  • Upon user creation, whether a password is assigned or not, the user shall enter a "Staged" state until activated by an import, API call, or manual intervention.
  • Once the activation process is complete, the account's status will change.
    • If the account was created with a password, it will transition to "Active" status, and the user will be able to access all the features and functionalities associated with the account. 
    • If the account was created without a password, it will transition to the "Pending User Action" status, which means that the user must take action, such as setting a password, before the account becomes fully activated.

Related References

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User with Staged Status is Set to Active when Pressing Activate Instead of Pending User Action