<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content

Slack Single Sign-On Fails From Okta With a "There's been a glitch" Error

Single Sign-On
Okta Classic Engine
Okta Identity Engine

Overview

A Single Sign-On (SSO) failure occurs when accessing Slack from Okta due to a misconfigured authentication request setting or an incorrect domain format. Enabling the authentication request signature in Slack or updating the domain format in the Okta integration resolves this issue. The SSO flow initiated from the Okta dashboard fails on the Slack page and displays the following error message:

 

There's been a glitch...

We're not quite sure what went wrong. You can go back, or try looking on our Help Center if you need a hand. 

 

Error Message

Applies To

  • Okta Identity Engine (OIE)
  • Okta Classic Engine
  • Slack
  • Single Sign-On (SSO)

Cause

The SSO flow fails due to a misconfiguration in the Slack SSO integration. The Sign AuthNRequest option must be enabled in Slack settings. Additionally, an incorrect Slack tenant URL format in the Okta integration causes this error.

Solution

What steps enable the authentication request signature in Slack?

Enable the authentication request signature in the Slack settings to ensure successful SSO connections.

  1. Navigate to the Slack SSO or authentication settings.
  2. Select the Sign AuthNRequest option.

"Sign AuthNRequest” option

 

The Slack Domain Format Requires an Update in the Okta Integration

Update the domain format in the Okta integration to match the enterprise Slack tenant URL.

  1. Navigate to the General tab of the Slack integration in Okta.
  2. Locate the Domain field.
  3. Enter <domain.enterprise> instead of <domain> if the Slack tenant URL follows the Enterprise Slack URL https://domain.enterprise.slack.com format rather than the Standard Slack URL https://domain.slack.com format.

 

Related References

Loading
Slack Single Sign-On Fails From Okta With a "There's been a glitch" Error | Okta Support