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Slack Deprovisioning Error "Refresh token response contained empty access token"
Okta Integration Network
Overview

A user is deactivated in Okta, but the deactivation did not flow through to Slack, and the following error is visible in the Okta dashboard:

Error while deactivating user <user>: Refresh token response contained empty access token. instanceId=<instanceId> tokenId=<tokenId>
 

Applies To
  • Slack
  • Provisioning
  • Error
Cause
This error is generated because the Slack credentials used to create the API connection are invalid.
Solution
  1. Go to Okta Admin Console and navigate to Applications > Applications > Slack > Provisioning > Integration > click the Edit button.

  2. Click Re-authenticate with Slack. The Slack application opens in a new window.

Provisioning

  1. Sign in to Slack with valid credentials and click Authorize. The Slack window will close, and the admin will be returned to the Okta Admin Console, and the message Slack was verified successfully appears.

  2. Click Save.
    Provisioning 

  3. Afterward, attempt to deprovision the user again. Navigate to Dashboard > Tasks. Any failed task should appear under Tasks.

  4. After identifying the failed task for the user that should be retried, click on Retry Selected.

 

Related References

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Slack Deprovisioning Error "Refresh token response contained empty access token"