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Slack Provisioning Error "Automatic provisioning of user to app Slack failed: Error while verifying if user exists: Refresh token response contained empty access token"
Okta Integration Network
Overview

Slack provisioning flow fails with the following error visible in the Okta dashboard:
 

Automatic provisioning of user <user> to app Slack failed: Error while verifying if user <user> exists: Refresh token response contained empty access token. instanceId=<instanceId> tokenId=<tokenId>
 

Error Message

Applies To
  • Slack
  • Provisioning
Cause
This error is generated because the Slack credentials used to create the API connection are invalid.
Solution
  1. Go to the Okta Admin Console and navigate to Applications > Applications > Slack > Provisioning > Integration > click the Edit button.
  2. Click Re-authenticate with Slack. The Slack application opens in a new window.

Re-authenticate with Slack button 

  1. Sign in to Slack with valid credentials and click Authorize. The Slack window will close, and the user will be redirected to the Okta Admin Console. The message Slack was verified successfully will appear.

  2. Click Save.
    Save button 

  3. Afterward, attempt the user provisioning again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.

 Tasks

  1. After identifying the failed task for the user that should be retried, click on Retry Selected.

 

Related References

 
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Slack Provisioning Error "Automatic provisioning of user to app Slack failed: Error while verifying if user exists: Refresh token response contained empty access token"