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Okta RADIUS Authentication Failure Despite Correct Credentials

Okta Classic Engine
Multi-Factor Authentication

Overview

Despite entering the correct credentials, RADIUS authentication via Okta fails due to invalid credentials.

Applies To

  • RADIUS
  • Amazon Workspace
  • Okta Classic Engine
  • Multi-Factor Authentication (MFA)

Cause

RADIUS secret contains special characters (for example, |, &, $).

Solution

Remove the special characters from the RADIUS secret by following these steps: 

  1. Navigate to the Okta Admin Console > Applications > Applications.
  2. Search for the configured RADIUS Applicationthen click it.
  3. Go to the Sign On tab, and in the Settings section, click on Edit.
  4. Reenter the Secret key, ensure no special characters are added, and press Save.

Secret key  

  1. Restart the RADIUS service on the RADIUS server to confirm that the secret is updated on the backend.
 

NOTE:

  • Please ensure the RADIUS Secret Key is updated in the application that uses it.
  • The Secret Key can be up to 16 characters long.
  • Please make sure that the RADIUS Service on the server is restarted, especially if AWS is used.
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Okta Support - Okta RADIUS Authentication Failure Despite Correct Credentials