Authentication Failure with AWS Amazon Workspaces with Okta MFA
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Overview
This article explains an authentication failure that occurs when attempting to sign in to AWS Amazon Workspaces with Okta Multi-Factor Authentication (MFA) over a Remote Authentication Dial-In User Service (RADIUS) connection. The following error is displayed:
Please check your username and password to make sure you typed them correctly. Please note that depending on the policy of your organization, you may also need to enter domain\username in the username text box.
Applies To
- Okta RADIUS
- Amazon Workspaces
Cause
The AWS directory account credentials are incorrect. Amazon Workspaces performs the primary authentication and then requests Okta to perform the secondary authentication (MFA). This error indicates the primary authentication attempt is failing.
Solution
In this kind of situation, AWS credentials might not be correctly introduced. Please confirm that the correct AWS credentials are used.
