Okta Verify Error "We found some errors. Please review the form and make corrections." When Device Time Is Incorrect
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Overview
Okta Verify authentication fails when the time and date on the device do not match the time on the Okta server. Resolve this issue by setting the device to use an automatic or network-provided time and date. When a user attempts to authenticate into Okta using Okta Verify, the authentication fails, and Okta displays the following error message:
We found some errors. Please review the form and make corrections.
Invalid code. Try again.
Applies To
- Okta Identity Engine
- Okta Classic
- Okta Verify
- Multi-Factor Authentication (MFA)
- One-Time Password (OTP)
Cause
The device has an incorrect date and time compared to universal time. Okta Verify One-Time Passcode (OTP) is a time-based factor that generates a passcode based on the time and date of the device. If the device time and date do not match those on the Okta server, the provided passcode does not match the expected passcode.
Solution
How is the Okta Verify form correction error resolved?
Synchronize the server and the device to ensure the generated OTP matches the expected code on the Okta server. Set the device to an automatic date and time to ensure the clock regularly synchronizes with a reliable internet time server. Update the time and date settings for the specific operating system by reviewing the appropriate external documentation.
Review the following platform resources to update device time settings.
