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Office365 SSO User Loop During Authentication
Single Sign-On
Okta Integration Network
Okta Classic Engine
Overview

This article addresses a common issue faced by Office 365 SSO users, where they find themselves caught in an authentication loop while trying to access their applications. This is often caused by either of the following reasons:

  1. When "Use Okta MFA for AzureAD" is enabled, Okta cannot match the MFA requirements set in Microsoft (AzureAD or Entra).
  2. When a user's password has expired in the Local Active Directory (AD) or Azure Active Directory (AAD).
Applies To
  • Office365 SSO User
  • Office365 Apps
  • Office365 WS-Fed
  • Use Okta MFA for AzureAD
  • Okta Identity Engine (OIE)
Cause

The primary causes for this issue are:

  1. If, on the Microsoft side, the user account falls under a stronger MFA policy than the one in Okta, Microsoft will expect 2 MFA tokens to be provided so that their requirement is satisfied, while in Okta, the affected user only triggers a 1FA Authentication Rule.
  2. An expired user password in either the Local Active Directory (AD) or Azure Active Directory (AAD).
Solution
  1. Firstly, to narrow down the root cause, start by creating an "Auth Loop Test" Office365 Authentication Rule:
    1. From the Okta Admin Dashboard, open the Microsoft Office 365 integration.

    2. Under the Sign On tab, scroll down to the bottom of the page.

    3. Click on View policy details.

    4. Create a new rule with the following mandatory settings:

      1. User is: select at least one affected user.

      2. Client is: One of the following clients: Web browser Modern Authentication.

      3. User must authenticate with: any combination from the 2-factor types section.

      4. Save.

      5. Move the Test rule as 1st Priority, to make sure the user triggers it.

        SSO policy   

      6. Check the authentication flow by making sure that the MFA prompt is triggered. If this flow is not encountering the looping issue, then the user will have to be either configured to trigger other existing 2FA rules or (not recommended) removed from the Conditional Access Policy in Azure or Entra that enforces MFA.

         

NOTE: Remember, keeping the Office 365 Authentication Policies stronger in Okta than Microsoft when using the "Use Okta MFA for AzureAD" option is critical in maintaining seamless access to Office 365 Apps.

 

  1.  In case the looping continues, resume troubleshooting with the following steps:
    1. Reset User Password: Begin by resetting the user's password in the AD. Make sure to sync this new password with AAD. This action ensures the user's credentials are updated in the Office 365 Portal.

    2. Clear Browser Cache and Cookies: Next, clear the cache and cookies from the user's browser. This action removes any stored data that could be causing the authentication loop.

    3. Login via Okta in Incognito Window: Open an incognito window in the user's browser and have the user log into Okta. Then, click on the Office365 App.

    4. Reset Password at Microsoft Login Page: The previous step will redirect the user to the Microsoft login page, where they can reset their password again.

    5. Logout and Login Again: Finally, have the user log out of Okta and log back in. The user should now be able to access the Office 365 applications without getting stuck in an authentication loop.


NOTE: Remember, keeping user passwords updated and in sync across different platforms is critical in maintaining seamless access to Office 365 Apps.

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Office365 SSO User Loop During Authentication