<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content

Okta Access Gateway Shows "Too many redirects" Error On Newly Deployed Node

Access Gateway
Okta Classic Engine
Okta Identity Engine

Overview

A newly deployed Okta Access Gateway (OAG) node that fails to bootstrap successfully displays a redirect error when accessing the admin console. Resetting and rebooting the node from the management console resolves the issue.

When accessing https://admin on the newly deployed node, the browser displays the following error:

 

Too many redirects.

 

The browser prompts the user to clear cookies, but the issue persists after clearing them all.

Applies To

  • Okta Identity Engine (OIE)
  • Okta Classic Engine
  • Okta Access Gateway (OAG)

Cause

The new node has not been bootstrapped successfully.

Solution

How is the "Too many redirects" error resolved on a newly deployed node?

Reset the system and reboot the node from the management console to resolve the redirect error.

  1. Sign in to the management console.
  2. Navigate to 5 - System > 7 - Reset.
  3. Enter y to reset.
  4. Enter y to initialize.
  5. Enter x to return to the main menu.
  6. Navigate to 5 - System > 5 - Reboot.
  7. Enter y to reboot.
  8. Access https://admin from the browser after the node restarts.
  9. Verify that the host file maps the correct IP address for the admin console.
Loading
Okta Support - Okta Access Gateway Shows "Too many redirects" Error On Newly Deployed Node