New BambooHR Users Are Not Imported into Okta
Last Updated:
Overview
Applies To
- BambooHR
- Imports
- Okta Integration Network (OIN)
Cause
There are two separate potential causes for this.
- BambooHR provisioning has a Pre-Start Interval configuration.
- The user is stuck on the Import tab because they are missing attribute values in their BambooHR profile that are required for User Creation & Matching.
Solution
Modify the BambooHR Pre-Start Interval to include/accommodate the new users' start date.
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In the Okta Admin Console, click Applications > Applications and click the BambooHR application.
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Click Provisioning > API Integration > Pre-Start Interval.
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Enter the interval in days. Users with the Hire Date within this interval will be considered active and imported to Okta. For example, if 7 is entered, users with a Hire Date will not be imported more than 1 week before the current date.
Ensure the user profile in BambooHR has the required values entered for the attributes configured in the User Creation & Matching settings.
- In the Okta Admin Console, click Applications > Applications and click the BambooHR application.
- Click Provisioning > To Okta > confirm the attributes configured for User Creation & Matching.
- Verify in BambooHR that the user profile has values for the required attributes; if empty, enter values and then perform the Import.
