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New BambooHR Users Are Not Imported into Okta
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview
New BambooHR users are not imported into Okta.
Applies To
  • BambooHR
  • Imports
  • Okta Integration Network (OIN)
Cause

There are two separate potential causes for this.

  • BambooHR provisioning has a Pre-Start Interval configuration.
  • The user is stuck in the Import tab because they are missing attribute values in their BambooHR profile required for User Creation & Matching.
Solution

Modify the BambooHR Pre-Start Interval to include/accommodate the new users' start date.

  1. In the Okta Admin Console, click Applications > Applications and click the BambooHR application.

  2. Click Provisioning > API Integration > Pre-Start Interval.


BambooHR Pre-Start Interval  

  1. Enter the interval in days. Users with the Hire Date within this interval will be considered active and imported to Okta. For example, if entered 7, the users with a Hire Date will not be imported later than one week ahead of the current date.

Ensure the user profile in BambooHR has the required values entered for the attributes configured in the User Creation & Matching settings.

  1. In the Okta Admin Console, click Applications > Applications and click the BambooHR application.
  2. Click Provisioning > To Okta > confirm the attributes configured for User Creation & Matching.
  3. Verify in BambooHR that the user profile has values for the required attributes; if empty, enter values and then perform the Import.


Related References

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New BambooHR Users Are Not Imported into Okta