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How to Identify If an O365 License Should Be Available in Okta
Okta Integration Network
Okta Classic Engine
Overview

This article explains how to determine whether an O365 license should be available in Okta.

Applies To
  • Office 365 Licenses
  • Federated O365
  • License Management
  • Okta Classic Engine
Cause

This issue is commonly caused by entering the wrong license name search term and failing to find a matching license. 


NOTE: Due to a Microsoft product limitation, Okta cannot fetch the exact same MS license name displayed in the MS Azure Portal/MS 365 Admin Center UX, as Okta uses Graph/PowerShell functions to fetch MS licenses from Microsoft into Okta for O365 app license assignment functionality. 


This is causing an Okta Admin to be unable to see an identical O365 license name that matches the identical MS license name as shown in the MS Azure Portal/MS 365 Admin Center.


This is being fully explained in Microsoft documentation, as shown in the screenshot below:
Microsoft 


Please always follow the documented solution steps to identify the correct corresponding license name when configuring the Office 365 app assignment > License assignment step. 


Okta Admin users should always refer to the latest MS documentation or contact the Microsoft Support Team to determine the correct license name to select for Okta/O365 app license assignment. 

Solution

Licenses for the Okta O365 application profile are obtained from Microsoft using Microsoft's Graph Explorer, which pulls in all the necessary data to display the licenses.

For the licenses to be refreshed and new application data to be brought over from O365, it is simple enough to Re-Authenticate the O365 API by navigating to the Applications > Applications > Microsoft Office 365 Okta Integration, clicking on the Provisioning tab > Integration > Edit, clicking on the Reauthenticate with Microsoft Office 365  button and logging in with the account mentioned below the button (should be a Global Administrator account that is used only for Provisioning). An alternative way of refreshing the licenses would be to navigate to the Applications > Applications section and click on the More > Refresh Application Data button. It is recommended to try the above option first, as Refresh Application Data imports data for all provisioning-enabled applications.
 

Using Graph API, data can be obtained about the licenses for a specific user or the licenses available for the org. There are two calls of interest that can be used for gathering the required data:

The responses will be a JSON doc that outlines the plans and SKUs used, which are shown below:
JSON 


Executing the https://graph.microsoft.com/v1.0/subscribedSkus endpoint using an API client (for example, Postman or Microsoft Graph Explorer) will return a comprehensive list of all subscriptions associated with the tenant in the response.

To determine the licenses possessed based on this information, please refer to the attributes provided on this page: Product names and service plan identifiers for licensing.

The relevant attributes for reference are as follows:

  • skuId: GUID
  • skuPartNumber: string ID

For example:

Example


Related References

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How to Identify If an O365 License Should Be Available in Okta