Removing Uninstalled RADIUS Agents from the Okta Agent Status Page
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Overview
Unlike other agents, Okta Remote Authentication Dial-In User Service (RADIUS) agents lack a direct, one-to-one link to an AppInstance. Because the client environment hosts the agent, Okta cannot determine if an administrator uninstalled the agent or disconnected it from the network, leaving uninstalled agents visible on the Agent Status page indefinitely. Revoking the API token transitions the agent to an inactive status after seven days, allowing administrators to hide it from the dashboard.
Applies To
- Okta Identity Engine (OIE)
- Okta Classic Engine
- Okta RADIUS Agent
- Multi-Factor Authentication (MFA)
Cause
The API token status populates the RADIUS agent status page. Because the client environment hosts the agent, Okta cannot ascertain if an administrator uninstalled the agent or disconnected it from the network. Even after an administrator uninstalls an agent, it remains visible on the Agents Dashboard indefinitely.
Solution
How does an administrator remove uninstalled RADIUS agents from the Agent Status page?
Revoke the API token in the Okta Admin Console to transition the agent to an inactive status, and then mark the agent as hidden on the dashboard.
- Navigate to Security and select API in the Okta Admin Console.
- Select the Tokens tab.
- Locate the token associated with the uninstalled RADIUS agent.
- Select Revoke next to the appropriate token.
NOTE: When an administrator revokes the API token, the status of the agent transitions from DISRUPTED to INACTIVE after seven days.
- Navigate to Dashboard, select Agents, and choose the RADIUS tab.
- Select the three dots next to the inactive agent.
- Select Mark as hidden agent.
