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How to Edit Group Rules
Lifecycle Management
Okta Classic Engine
Okta Identity Engine
Overview
Admins may need to change group settings to keep up with the group's changing needs and member requirements. Such changes could include modifying the conditions upon which users are assigned to a group or excluded from a group. To do so, one can navigate to the Admin Console, select Directory > Groups, and access the Rules tab to locate and edit the relevant rule.
Applies To
  • Groups
  • Group Rules
Cause
In some scenarios, an Administrator is unable to see the Edit option when trying to modify a group rule. This issue occurs when the group rule is still active. Only inactive group rules can be edited.
Solution

Please see the video below for more details.


 The following process should be followed to edit group rules:

Provide detailed steps to successfully implement the solution or workaround for the problem. Include step-by-step instructions whenever possible.

  1. Log in to the Admin Console as a Super Admin.
  2. Navigate to Directory > Groups.
  3. Select the Rules tab.
  4. Find the rule that needs to be edited and click the Actions menu.
  5. Select Deactivate to deactivate the rule.
Deactivate rule
  1. Click the Actions menu again, and the Edit option should now appear.
NOTE: The one element Admins cannot delete or edit is the "Assign to" group. To remove or change a previously assigned group, Admins must delete the rule and create a new one. 
 
  1. Once the rule has been updated, click Save.
Save button 
  1. Reactivate by pressing Activate in the Actions menu.

Activate rule

 
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How to Edit Group Rules