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How to Remove a User from a Group Rule Exclusion List
Okta Identity Engine
Okta Classic Engine
Administration
Overview

This guide aims to explain how to remove a user from the exclusion list of a group membership rule.

Applies To
  • Groups
  • Group Rules
Cause

A user is automatically added to the group membership exclusion list in cases where the following criteria requirements are met:

  1. The user was assigned to the group using a group membership rule.
  2. The user is manually removed from the group.

When a user is removed from a group that was assigned using a group rule, Okta System (System Principal) will add the user to the group rule exclusion list with the message:

User added to exclusion list for group rule.
 

The user can also be manually added or removed from the exclusion list by following the steps below.
 

Solution

To remove a user who is on the group rule's exclusion list from the Admin Console, please follow the video or the steps below:


 

  1. Navigate to the Directory > Groups > Rules tab > and search for the rule. Once found, temporarily deactivate the rule to edit it by clicking Actions > Deactivate.

deactivate group rule

 

  1. After deactivating the rule, click on Actions once more and click Edit.

edit rule 

  1. In the EXCEPT section, search for the user's name and click on the x symbol situated on the right side of the user's name.

EXCEPT section


Related References

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How to Remove a User from a Group Rule Exclusion List